re = /For .+EachIn .+;/m
str = ' foreach (var VARIABLE in COLLECTION)
{
}
For Local tUiObj ob=EachIn tScreen.Active().sub;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result