# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]*src="([^"]+)"[^>]*>|<a\b.+?<\/a>(*SKIP)(*F)/<a href="$1">$0<\/a>/gis;t' <<< "
<img src=\"/img/file1.jpg\" />
<a href=\"/img/file2.jpg\"><img src=\"/img/file2.jpg\" /></a>
<img src=\"/img/file3.jpg\" />
"