# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img[^>]*src=\"([^\"]+)\"[^>]*>|<a\b.+?</a>(*SKIP)(*F)"
test_str = ("\n"
" <img src=\"/img/file1.jpg\" />\n\n"
" <a href=\"/img/file2.jpg\"><img src=\"/img/file2.jpg\" /></a>\n\n"
" <img src=\"/img/file3.jpg\" />\n\n")
subst = "<a href=\"$1\">$0</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.