const regex = new RegExp('<img[^>]*src="([^"]+)"[^>]*>|<a\\b.+?</a>(*SKIP)(*F)', 'gis')
const str = `
<img src="/img/file1.jpg" />
<a href="/img/file2.jpg"><img src="/img/file2.jpg" /></a>
<img src="/img/file3.jpg" />
`;
const subst = `<a href="$1">$0</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);