use strict;
my $str = '
<img src="/img/file1.jpg" />
<a href="/img/file2.jpg"><img src="/img/file2.jpg" /></a>
<img src="/img/file3.jpg" />
';
my $regex = qr~<img[^>]*src="([^"]+)"[^>]*>|<a\b.+?</a>(*SKIP)(*F)~isp;
my $subst = '<a href="$1">$0</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";