// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<img[^>]*src="([^"]+)"[^>]*>|<a\b.+?</a>(*SKIP)(*F)"#).unwrap();
let string = "
<img src=\"/img/file1.jpg\" />
<a href=\"/img/file2.jpg\"><img src=\"/img/file2.jpg\" /></a>
<img src=\"/img/file3.jpg\" />
";
let substitution = "<a href=\"$1\">$0</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}