package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<img[^>]*src="([^"]+)"[^>]*>|<a\b.+?</a>(*SKIP)(*F)`)
var str = `
<img src="/img/file1.jpg" />
<a href="/img/file2.jpg"><img src="/img/file2.jpg" /></a>
<img src="/img/file3.jpg" />
`
var substitution = "<a href="$1">$0</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}