import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*src=\"([^\"]+)\"[^>]*>|<a\\b.+?</a>(*SKIP)(*F)";
final String string = "\n"
+ " <img src=\"/img/file1.jpg\" />\n\n"
+ " <a href=\"/img/file2.jpg\"><img src=\"/img/file2.jpg\" /></a>\n\n"
+ " <img src=\"/img/file3.jpg\" />\n\n";
final String subst = "<a href=\"$1\">$0</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}