using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]*src=""([^""]+)""[^>]*>|<a\b.+?</a>(*SKIP)(*F)";
string substitution = @"<a href=""$1"">$0</a>";
string input = @"
<img src=""/img/file1.jpg"" />
<a href=""/img/file2.jpg""><img src=""/img/file2.jpg"" /></a>
<img src=""/img/file3.jpg"" />
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}