$re = '~<img[^>]*src="([^"]+)"[^>]*>|<a\b.+?</a>(*SKIP)(*F)~is';
$str = '
 <img src="/img/file1.jpg" />
 <a href="/img/file2.jpg"><img src="/img/file2.jpg" /></a>
 <img src="/img/file3.jpg" />
';
$subst = "<a href=\"$1\">$0</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;