#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)\[([a-zA-Z]\w*)|([^=\s]+)=["'](.*?)["']"
Local $sString = "Hello, My name is Jack, This is my selfie:" & @CRLF & _
"[img id='b' src="imageurl" card="asd"]" & @CRLF & _
"Below is the quick-link to my profile" & @CRLF & _
"[profile username='jackisbest']" & @CRLF & _
"" & @CRLF & _
"[sometag someatt='value' temp="qwetry']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")