$re = '/\[([a-zA-Z]\w*)|([^=\s]+)=["\'](.*?)["\']/ims';
$str = 'Hello, My name is Jack, This is my selfie:
[img id=\'b\' src="imageurl" card="asd"]
Below is the quick-link to my profile
[profile username=\'jackisbest\']
[sometag someatt=\'value\' temp="qwetry\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);