re = /\[([a-zA-Z]\w*)|([^=\s]+)=["'](.*?)["']/im
str = 'Hello, My name is Jack, This is my selfie:
[img id=\'b\' src="imageurl" card="asd"]
Below is the quick-link to my profile
[profile username=\'jackisbest\']
[sometag someatt=\'value\' temp="qwetry\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end