// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ims)\[([a-zA-Z]\w*)|([^=\s]+)=["'](.*?)["']"#).unwrap();
let string = "Hello, My name is Jack, This is my selfie:
[img id='b' src=\"imageurl\" card=\"asd\"]
Below is the quick-link to my profile
[profile username='jackisbest']
[sometag someatt='value' temp=\"qwetry']";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}