import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([a-zA-Z]\\w*)|([^=\\s]+)=[\"'](.*?)[\"']";
final String string = "Hello, My name is Jack, This is my selfie:\n"
+ "[img id='b' src=\"imageurl\" card=\"asd\"]\n"
+ "Below is the quick-link to my profile\n"
+ "[profile username='jackisbest']\n\n"
+ "[sometag someatt='value' temp=\"qwetry']";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}