const regex = /\[([a-zA-Z]\w*)|([^=\s]+)=["'](.*?)["']/gims;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([a-zA-Z]\\w*)|([^=\\s]+)=["\'](.*?)["\']', 'gims')
const str = `Hello, My name is Jack, This is my selfie:
[img id='b' src="imageurl" card="asd"]
Below is the quick-link to my profile
[profile username='jackisbest']
[sometag someatt='value' temp="qwetry']`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}