import re
regex = re.compile(r"\[([a-zA-Z]\w*)|([^=\s]+)=[\"'](.*?)[\"']", flags=re.IGNORECASE | re.MULTILINE | re.DOTALL)
test_str = ("Hello, My name is Jack, This is my selfie:\n"
"[img id='b' src=\"imageurl\" card=\"asd\"]\n"
"Below is the quick-link to my profile\n"
"[profile username='jackisbest']\n\n"
"[sometag someatt='value' temp=\"qwetry']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")