using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([a-zA-Z]\w*)|([^=\s]+)=[""'](.*?)[""']";
string input = @"Hello, My name is Jack, This is my selfie:
[img id='b' src=""imageurl"" card=""asd""]
Below is the quick-link to my profile
[profile username='jackisbest']
[sometag someatt='value' temp=""qwetry']";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}