# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(href="[^"]+)'([^"]+")/$1$2/gm;t' <<< "This is an example text. I'd love to fix this.
<a href=\"https://www.example.com/i'd-love-to-fly/\"> I'd love to fly link </a>
Inside the text there could be more urls
<a href=\"https://www.example.com/i'd-rather/\">I'd rather link</a>. "