using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(href=""[^""]+)'([^""]+"")";
string substitution = @"$1$2";
string input = @"This is an example text. I'd love to fix this.
<a href=""https://www.example.com/i'd-love-to-fly/""> I'd love to fly link </a>
Inside the text there could be more urls
<a href=""https://www.example.com/i'd-rather/"">I'd rather link</a>. ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}