// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(href="[^"]+)'([^"]+")"#).unwrap();
let string = "This is an example text. I'd love to fix this.
<a href=\"https://www.example.com/i'd-love-to-fly/\"> I'd love to fly link </a>
Inside the text there could be more urls
<a href=\"https://www.example.com/i'd-rather/\">I'd rather link</a>. ";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}