import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(href=\"[^\"]+)'([^\"]+\")";
final String string = "This is an example text. I'd love to fix this. \n\n"
+ "<a href=\"https://www.example.com/i'd-love-to-fly/\"> I'd love to fly link </a> \n\n"
+ "Inside the text there could be more urls \n\n"
+ "<a href=\"https://www.example.com/i'd-rather/\">I'd rather link</a>. ";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}