const regex = /(href="[^"]+)'([^"]+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(href="[^"]+)\'([^"]+")', 'gm')
const str = `This is an example text. I'd love to fix this.
<a href="https://www.example.com/i'd-love-to-fly/"> I'd love to fly link </a>
Inside the text there could be more urls
<a href="https://www.example.com/i'd-rather/">I'd rather link</a>. `;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);