$re = '/(href="[^"]+)\'([^"]+")/m';
$str = 'This is an example text. I\'d love to fix this.
<a href="https://www.example.com/i\'d-love-to-fly/"> I\'d love to fly link </a>
Inside the text there could be more urls
<a href="https://www.example.com/i\'d-rather/">I\'d rather link</a>. ';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;