#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(href="[^"]+)'([^"]+")"
Local $sString = "This is an example text. I'd love to fix this. " & @CRLF & _
"" & @CRLF & _
"<a href="https://www.example.com/i'd-love-to-fly/"> I'd love to fly link </a> " & @CRLF & _
"" & @CRLF & _
"Inside the text there could be more urls " & @CRLF & _
"" & @CRLF & _
"<a href="https://www.example.com/i'd-rather/">I'd rather link</a>. "
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)