import re
regex = re.compile(r"(href=\"[^\"]+)'([^\"]+\")", flags=re.MULTILINE)
test_str = ("This is an example text. I'd love to fix this. \n\n"
"<a href=\"https://www.example.com/i'd-love-to-fly/\"> I'd love to fly link </a> \n\n"
"Inside the text there could be more urls \n\n"
"<a href=\"https://www.example.com/i'd-rather/\">I'd rather link</a>. ")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)