use strict;
my $str = 'This is an example text. I\'d love to fix this.
<a href="https://www.example.com/i\'d-love-to-fly/"> I\'d love to fly link </a>
Inside the text there could be more urls
<a href="https://www.example.com/i\'d-rather/">I\'d rather link</a>. ';
my $regex = qr/(href="[^"]+)'([^"]+")/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";