# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+/@/gm;t' <<< "words before 879 then more words then 1001 again"