use strict;
my $str = 'words before 879 then more words then 1001 again';
my $regex = qr/^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+/mp;
my $subst = '@';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";