// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+").unwrap();
let string = "words before 879 then more words then 1001 again";
let substitution = "@";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}