package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+`)
var str = `words before 879 then more words then 1001 again`
var substitution = "@"
fmt.Println(re.ReplaceAllString(str, substitution))
}