#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+"
Local $sString = "words before 879 then more words then 1001 again"
Local $sSubst = "@"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)