re = /^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+/m
str = 'words before 879 then more words then 1001 again'
subst = '@'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result