const regex = /^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:\\S+\\s*){3}(*SKIP)(*FAIL)|\\d+', 'gm')
const str = `words before 879 then more words then 1001 again`;
const subst = `@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);