$re = '/^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+/m';
$str = 'words before 879 then more words then 1001 again';
$subst = "@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;