import Foundation
let pattern = #"^\s*(?:\S+\s*){3}(*SKIP)(*FAIL)|\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"words before 879 then more words then 1001 again"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)