#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\b([^\s*][a-zA-Z_\.\s]+)\b"
Local $sString = "Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)