import Foundation
let pattern = #"\b([^\s*][a-zA-Z_\.\s]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)