const regex = new RegExp('\\b([^\\s*][a-zA-Z_\\.\\s]+)\\b', 'gmi')
const str = `Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);