using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([^\s*][a-zA-Z_\.\s]+)\b";
string substitution = @"";
string input = @"Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}