import re
regex = re.compile(r"\b([^\s*][a-zA-Z_\.\s]+)\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)