$re = '/\b([^\s*][a-zA-Z_\.\s]+)\b/mi';
$str = 'Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;