re = /\b([^\s*][a-zA-Z_\.\s]+)\b/mi
str = 'Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result