#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)tags:\s*(.+?)\n\s*\d"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" “Don't cry because it's over, smile because it happened.”" & @CRLF & _
" ?" & @CRLF & _
" Dr. Seuss" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" tags:" & @CRLF & _
" attributed-no-source," & @CRLF & _
" cry," & @CRLF & _
" crying," & @CRLF & _
" experience," & @CRLF & _
" happiness," & @CRLF & _
" joy," & @CRLF & _
" life," & @CRLF & _
" misattributed-dr-seuss," & @CRLF & _
" optimism," & @CRLF & _
" sadness," & @CRLF & _
" smile," & @CRLF & _
" smiling" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 176513 likes" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Like" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")