re = /(?s)tags:\s*(.+?)\n\s*\d/
str = '
“Don\'t cry because it\'s over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end