package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)tags:\s*(.+?)\n\s*\d`)
var str = `
“Don't cry because it's over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}