import re
regex = re.compile(r"(?s)tags:\s*(.+?)\n\s*\d")
test_str = ("\n\n\n"
" \n\n\n"
" “Don't cry because it's over, smile because it happened.”\n"
" ?\n"
" Dr. Seuss\n\n\n\n\n"
" \n"
" tags:\n"
" attributed-no-source,\n"
" cry,\n"
" crying,\n"
" experience,\n"
" happiness,\n"
" joy,\n"
" life,\n"
" misattributed-dr-seuss,\n"
" optimism,\n"
" sadness,\n"
" smile,\n"
" smiling\n"
" \n"
" \n"
" 176513 likes\n"
" \n\n\n\n\n"
"Like\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")