using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)tags:\s*(.+?)\n\s*\d";
string input = @"
“Don't cry because it's over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}