$re = '/(?s)tags:\s*(.+?)\n\s*\d/';
$str = '
“Don\'t cry because it\'s over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);