import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)tags:\\s*(.+?)\\n\\s*\\d";
final String string = "\n\n\n"
+ " \n\n\n"
+ " “Don't cry because it's over, smile because it happened.”\n"
+ " ?\n"
+ " Dr. Seuss\n\n\n\n\n"
+ " \n"
+ " tags:\n"
+ " attributed-no-source,\n"
+ " cry,\n"
+ " crying,\n"
+ " experience,\n"
+ " happiness,\n"
+ " joy,\n"
+ " life,\n"
+ " misattributed-dr-seuss,\n"
+ " optimism,\n"
+ " sadness,\n"
+ " smile,\n"
+ " smiling\n"
+ " \n"
+ " \n"
+ " 176513 likes\n"
+ " \n\n\n\n\n"
+ "Like\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}